Post here if you encounter any bugs.
By Wendigo
#67468 Running a game on mobile makes the images look low resolution even at high resolution. (Native Electron and HTML5 export looks good)
The "Smooth the image" setting is active for all images.
Sakawochi was designed for a resolution of 1600x900.

Android 4.0.3:
Screenshot_android.png (38.43 KiB) Viewed 1169 times

Ubuntu Touch 15.04:
screenshot_ubuntutouch.png (159.33 KiB) Viewed 1169 times

Native (smooth as it should be)
screenshot_native.png (119.76 KiB) Viewed 1157 times
Last edited by Wendigo on Sun 29 Jul 2018, 17:38, edited 1 time in total.
By Rikazu
#67473 Your base image size should be a lot bigger so it will not be stretched too much, but rather compressed. It happens too if you resize a window (desktop) whereas it shows as a blurred stretched image, but if you make the image bigger it will show just fine, since it doesn't stretch it that much.
By Wendigo
#67474 I already had to shrink the images down in the scene editor to make them fit in the scene.
I uploaded another image of the game exported as HTML5 in the same resolution as the Ubuntu Touch export but this one looks as crisp as it should.
User avatar
By Kink
#68083 Did you tried to disable image smoothing ? Personnaly i dislike smoothing, better for me to have aliased render than blurry.
User avatar
By Kink
#68354 Wendigo, have you seen this discussion in #general on discord :

Capture.PNG (114.46 KiB) Viewed 646 times

Links to images :

I had long talk with @nocry on discord, he seems to have corrected blurry images issue on his side by compiling himself.